API 503 Service Unavailable errors
Incident Report for seatsio
Postmortem

We hunted down the root cause of last night's problem: a bug in the best available seat API endpoint caused a deadlock under high load. This, in turn, resulted in failure of the other API endpoints, and ultimately seating chart renderings. We deployed a fix earlier today, all systems are go. Please do get in touch (support@seats.io) in case of questions!

Posted 12 months ago. Jun 28, 2018 - 15:26 CEST

Resolved
Our API is currently responding 503 Service Unavailable in an estimated 80% of the cases. This is affecting the rendering and the web app. We're sorry, we're on it and we will get back with an update within the next 15 minutes.

04:49:00 CEST
After restarting all of the services, we're seeing normal numbers again. We'll continue monitoring the situation and of course update here. Expect to hear from us again in the next 30 minutes.

05:15:08 CEST
The seats.io API and all other systems have been running normally for the past 30 minutes, so we can close this incident for now. Naturally, we will investigate and fix the root cause. We're sorry for the trouble this has caused!
Posted about 1 year ago. May 14, 2018 - 04:34 CEST