Connection issues with OpenSSL 1.0
Incident Report for seatsio
Resolved
This incident has been resolved.
Posted Sep 30, 2021 - 20:21 CEST
Identified
There is currently nothing we can do in the short term to work around the expiration of the Let's Encrypt Root CA X3, and the resulting SSL errors. Upgrading OpenSSL to 1.1 or later is the recommended solution.
Posted Sep 30, 2021 - 20:15 CEST
Investigating
Some users who are on OpenSSL 1.0 reported getting an SSL error, saying that our certificate expired. The certificates are not expired, but an old root certificate (DST Root CA X3) did expire, and that's causing issues with OpenSSL 1.0. Read more here: https://letsencrypt.org/docs/dst-root-ca-x3-expiration-september-2021/

Upgrading OpenSSL to 1.1 or later fixes the issue.

We will, from our side, see if there are things we can do to work around this issue.
Posted Sep 30, 2021 - 18:13 CEST
This incident affected: Seats.io API and Seats.io Web Application.