Postgres db flash crash
Incident Report for seatsio
Resolved
This incident has been resolved.
Posted 5 days ago. May 14, 2019 - 19:54 CEST
Monitoring
This morning at 2019-04-24 06:22:02 UTC, our Postgresql database crashed, likely due to a hardware failure.

Fortunately, the safety measures we have in place worked very well: a high availability standby database automatically took over within seconds. The seats.io API, Web app and chart renderings were largely unavailable for 1 minute 22 seconds, the time it took for the standby db to get up and running.

No data was lost.

Our infrastructure provider tells us "This is likely due to an underlying hardware or network failure and not something caused by your application". But of course, we are investigating as we speak, and will get to the bottom of this.
Posted 25 days ago. Apr 24, 2019 - 08:56 CEST
This incident affected: Seats.io API, Seats.io Web Application, and Seats.io Rendered Charts.